• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: No terminal recognizes the Plug  (Read 2723 times)
A_W
Newbie
*

Karma: 1
Posts: 25


View Profile
« on: December 07, 2009, 04:54:40 AM »

Hi, everybody!

After several attempts, using different computers, terminal software and cables, I have still not been able to make any computer connect to the Plug over the serial interface.

Installing CDM made the computer (Win XP) stop complaining about not recognizing the Plug as a valid USB device, so I must be doing something right.

The Plug is not dead, since I can ssh into it over the LAN, but in order to do what I want (i.e. boot it of an SD card), I have to use the serial interface instead, since someone decided to design the Plug in such a way that changing the boot order has to be done on the fly during boot-up, before ssh:ing into the Plug is even possible.
(In IBM lingo, the plug is "Broken As Designed", see http://catb.org/jargon/html/B/BAD.html.)

Does anyone have any suggestions as to how one can make the PC recognize the Plug, or is there some way to reprogram the boot order over ssh?

If not, I have simply bought a very expensive plastic brick.
Logged

ruidc
Newbie
*

Karma: 0
Posts: 36


View Profile
« Reply #1 on: December 07, 2009, 05:05:37 AM »

... this is your second thread on this issue, but...
have you tried following http://plugcomputer.org/plugwiki/index.php/How-to_setup_PuTTY_for_the_SheevaPlug_on_Windows ?

If so, at what stage do you get problems? what are the problems you get?
Logged

A_W
Newbie
*

Karma: 1
Posts: 25


View Profile
« Reply #2 on: December 07, 2009, 05:40:09 AM »

Yup, I've tried it.

The problem occurs at Step 6. The terminal application (wether PuTTY, HyperTerminal or any other) never gets any response from the Plug; the connection is just dead.
The physical connection is up, however, as the computer whined about not knowing what to do with the Plug (until I installed CDM).

Restarting the Plug or reestablishing the terminal connection is ineffective - I have tried over and over again.


(And yes, it IS my second thread on roughly the same thing. Desperation tends to produce that kind of behaviour Wink . I am very greatful that someone cares to answer.)
Logged

ruidc
Newbie
*

Karma: 0
Posts: 36


View Profile
« Reply #3 on: December 07, 2009, 05:50:46 AM »

K, let's agree to just use this thread.

1. I notice from http://plugcomputer.org/plugforum/index.php?topic=2.msg6450#msg6450 that you are using a non-english version of XP, what version are you using? As both professional and Home should have a device manager.
2. We need to verify that the drivers installed correctly, and this is the best place to do so.
3. do you get an error message or can you elaborate on the behaviour you are seeing?
The problem occurs at Step 6. The terminal application (wether PuTTY, HyperTerminal or any other) never gets any response from the Plug; the connection is just dead.
i know when i first connected i didn't know i'd been successful until i hit enter to re-send the ubuntu login prompt.

Regards,
RuiDC
Logged

A_W
Newbie
*

Karma: 1
Posts: 25


View Profile
« Reply #4 on: December 07, 2009, 06:01:10 AM »

I use swedish XP pro SP 2.

The terminal never gets beyond the "empty screen with insertion-block-character in the upper left corner" state.


Reply form the other thread:

On plug-in, windows notices the new hardware. Before CDM, windows complained that it didn't know what to do, but with CDM the computer says nothing. (The Plug does not even show up on "safe removal of hardware".)

The hardware manager (which I suppose is what is called "Device manager" in the english versions of Windows) does not detect the Plug at all. Before I installed CDM, the hardware wizard would start, but to no avail.

When I try to select driver files (through Control Panel > Add or remove software), the files in the "sheevaplug-installer-v1.0" directory (and each one of its sub-directories) do not show up. Changing view to "view all file types" makes them show up, but since they are not concidered installation files, it is forbidden to choose them. Hence, no install.
Logged

ruidc
Newbie
*

Karma: 0
Posts: 36


View Profile
« Reply #5 on: December 07, 2009, 06:37:57 AM »



The terminal never gets beyond the "empty screen with insertion-block-character in the upper left corner" state.

1. have you tried hitting enter when it is in that state? (as when it is working correctly that is all that is needed for me)
2. do you have any error messages on connecting with terminal program?
3. have you verified your connection settings as being:
correct Com port: com 4 for me as pictured and circled in the attached image.
Speed: 115200 bits per second
Data bits: 8
Parity: None or N
Stop bits: 1
Flow Control: None or N

Also, verify in device manager / hardware manager that you see the devices as per circled items in my screenshot attached, namely:
4. the two USB Serial converters
5. the USB Serial port


* dm_plug.GIF (25.35 KB, 1241x1754 - viewed 230 times.)
Logged

A_W
Newbie
*

Karma: 1
Posts: 25


View Profile
« Reply #6 on: December 07, 2009, 07:04:30 AM »

1.Hitting return does nothing, not even dropping the cursor one line.
2. No. No error messages.
3. Yes.

4. I finally found the "device manager". Thank you for the attached image!
Strangely enough, the USB serial port does not show up. USB serial coverters A and B do, though.

I have run the "update driver" wizard, but it couldn't find a better driver than the one already installed for the USB serial converters.
Logged

ruidc
Newbie
*

Karma: 0
Posts: 36


View Profile
« Reply #7 on: December 07, 2009, 07:09:00 AM »

you have missed a step from the wiki:
1. Open up Device Manager, and locate the USB Serial Controller device, it should show 2 child nodes ("Port A" and "Port B"). Port A is the JTAG port, and you should leave this as-is. Port B is the serial port, which you can log on via a serial terminal 2. NOTE: by default Windows does not load the Virtual Comm Ports for these 2 ports.
2. Click on Port B, select Properties, and on one of the tabs, there should be an option "Load VCP". This tells Windows to actually assign your Sheevaplug a real com-port that Putty can talk to.
3. Unplug and replug the Sheeva USB, it should now download/install the Virtual Comm Port. Make a note of what port number it's assigned it (it is usually 1 more than the maximum number of com ports you have on your computer).

then retry the connection from your terminal program.
Logged

A_W
Newbie
*

Karma: 1
Posts: 25


View Profile
« Reply #8 on: December 08, 2009, 12:25:38 AM »

Done - now it works!

A big load of thanks, ruidc! Cheesy
Logged

ruidc
Newbie
*

Karma: 0
Posts: 36


View Profile
« Reply #9 on: December 08, 2009, 01:51:09 AM »

I'm glad to hear that fixed your problem.

Thanks for confirming it works.

I guess the "take-away" from this one is to read the wiki/docs carefully and identify at which step you cannot follow the docs any further.

 Smiley
Logged

Pages: [1]
Print
Jump to: